TP-Link Unifi Router Setup Guide – 2019 version

TP-Link Unifi Setup Guide

TP-Link WiFi routers are fully compatible with TM Unifi. Upgrading to a new router will bring many benefits including better WiFi speed and a more reliable connection. In this article, we will guide you how to change your old router into a new TP-Link wireless router.

This article is applicable to the following TP-Link wireless router: Archer C5400X, C5400, C4000, C3150, C2300, A10, C9, A9, C7, A7, A6 and etc. You can refer to our Unifi router buying guide here.

Unifi PPPOE Username and Password

Example

You will need your Unifi PPPOE username and password to connect to the Internet. These can be obtained by contacting TM customer service. You will need to be the owner as TM will perform some identity verification.

Upon submitting a request, TM will call you back within 24 hours to provide you with the username and password. 

The next thing to do is to connect your new router to the TM modem. All Unifi installation comes with a modem and the router. The modem is labeled ONU and do not come with any antenna.

Disconnect the old wireless router from TM. Next, connect from LAN 1 of the Unifi modem to the WAN port of your new TP-Link router. If you use the HyppTV, connect it to the LAN1 of the TP-Link router.

TP-Link Unifi Setup Guide

Step 1: Turn on the new router

Power on the TP-Link router and connect it to your computer. You can either use an Ethernet cable to any of the LAN ports or use the WiFi connection. The default WiFi name and password is labeled on the wireless router. 

Although using a phone is technically possible but we recommend using a computer as the page is more desktop friendly.

Step 2: Navigate to the configuration page

Once you are connected to your new TP-Link router, navigate to 192.168.0.1 or tplinkwifi.net and you shall see this page below.

Step 3: Create a new admin password

The router will advice you to create a new admin password. Make sure you write it down as you may need it in the future.

Step 4: Select the time zone

Select the right time zone which is GMT +8 for Malaysia. This is needed for the router to determine the time correctly.

Step 5: Select the Internet connection type

This step requires you to select the ISP correctly in order for the Internet connection to work properly. 
  1. Select PPPOE as the internet connection type
  2. Expand the additional ISP settings
  3. Select Malaysia-Unifi profile!

Step 6: Insert the PPPOE username and password

Next, insert in the PPPOE username and password you obtained from TM in this screen. Be very careful when typing in the password as it is case-sensitive and many people got it wrong.

Step 7: Configure the WiFi connection

Then, we insert our desired WiFi name and password in this step. 

Step 8: Verify the summary

The router will now show you a summary of what is configured. We recommend checking through everything is selected as it is and click save.

Step 9: Apply the new configurations

The configuration part is now completed and the wireless router will reboot.

TP-Link Unifi Setup

Step 10: Complete and testing

After the reboot, you can connect to the Internet using the new WIFi name that you just configured. Next, check if the Internet and HyppTV is working properly. If everything works, we recommend downloading the TP-Link Tether app to manage your router from your phone. 

Troubleshooting

UI shows connected but unable to browse

If the firmware interface shows that you are actually connected to TM network and you have an IP, check if you use the correct PPPOE username and password. A wrong PPPOE username and password can let you to connect to TM network but without Internet access.

HyppTV is not working

If you face issues with HyppTV but Internet is working, check if the HyppTV is connected to LAN 1 as only the port can work for HyppTV.

Subscribe
Notify of
185 Comments
Inline Feedbacks
View all comments

Hi, i’m using TP-Link AX73. Currently not able to connect my HyppTv. I already choose Vlan mode Malaysia-unifi and connect my STB to Lan 1. I am using the white STB, not the UPB. Why is it still not connecting?

Hello, is there any possibility to change the LAN 1 reserved for IPTV to make it a usable internet port? This was possible on the D-link DIR-842 where the default port 4 was reserved for IPTV but can be switch to a usable LAN port for internet

everytime the last step “connection test” internet led on my ax20 will turn from green to orange then the setup will display oops the internet connection is not setup successfully…i have done dozen time setup this….reboot and setup again then on last step the light will turn to orange….already confirmed my pppoe username and password is correct….and already choose malaysia unifi as profile….please help…

hi same problem as Fizal. checked the wiring correct LAN 1 from TM modern. My old router still working. new AX20 same problem as Faizal. any helps ?

For the benefits of everyone, if you are facing black screen on Unifi TV after setting up your new TP Link router, do the following setting in your new router: Advanced > Network > IPTV/VLAN > Under Multicast, change IGMP Version from V2 to V3. Simple step and it shall work! TM will charge RM50+ for sending a technician over (@,@)

thanks for the info. just got my ax20 router yesterday and was having this problem. glad to found this solution. u just made my day. thanks again

I also just got ax20. I don’t see the additional ISP settings when choosing pppoe connection and now ax20 just show status “connecting”. How you make it ax20 to connect unifi modem?

Any idea how to setup VOIP for TM Unifi on archer vr600v

everytime change router need new PPPoE password from TM? no noob here.

Hi there,
I would like to ask, is TP Link C80 best for unifi 800mbps?
because i’ve using it and how do i get a stable connection speed with wifi and LAN connection.

Thanks..

will TP-Link Archer AX50 be ok for unifi?

i got xiaomi ax6000 how to set up ?

Hey blacktubi, I was trying to set up my new ax5400 tplink router for my unifi 30mbps, it is using a nexis modem/router. For some weird reason I am unable to set up the connection on the tplink (just doesn’t connect,my pppoe details are correct). wan of router is plugged to lan 1 of nexis modem/router.

Is there anything I need to configure on the nexis in order to connect to internet on the tplink?

Hi, is it the same step for Time Internet?

1 5 6 7
185
0
Would love your thoughts, please comment.x
Scroll to Top